arris tg3442


Was looking forward today on upgrading my internet to 1gb and having the stellar WiFi.

guess what ?

got a replacement router with the pods. Changed everything and No Connection.

seems the new router is faulty as it powers on only. Tried connecting to pc to access but nothing, tried resetting from the small button at the back but seems it does not reset neither.

well to cut it short now I have a full weekend without internet and since am working from home on Monday need to take it off from work till my modem is replaced.

 

Big Sigh

 

 

 


2 replies

Well an update. Router now works after replacement but NO VPN support so have huge problems with teleworking.

 

plume pods seem to be registered to someone else.

called and chatted with Melita support and seems utterly hopeless. It’s as if they hired a bunch of non tech people behind a phone and all they say is ID, name and surname etc. 

Hope they sort this out ASAP but I doubt.

After more than 15 years loyal customer I think it is time to move on.

Thank you very much for the help;

Reply